Emergency Reporting System Requirements

 

Emergency Reporting can run on any computer or mobile device with an Internet connection. We make every effort to test and support the most recent version of the following browsers:

  • Google Chrome
  • Mozilla Firefox
  • Microsoft Internet Explorer
  • Apple Safari
  • Microsoft Edge

 

Emergency Reporting does not recommend or support using older browsers at or below the following versions :

  • IE 10
  • Chrome 58.x
  • Edge 39.x
  • Firefox 53.x
  • Safari 6.x

 

To learn more about our system requirements and why this is important, click here.